Back to overview
Downtime

Some services are down

May 20, 2026 at 12:21am UTC
Affected services
Client-Cabinet
Backend Services
Login/Signup
License Portal

Resolved
May 20, 2026 at 2:28am UTC

Fully recovered

Updated
May 20, 2026 at 1:59am UTC

We’re back! All services should be up and running. The Backend Services could still show slow response times. Thanks for bearing with us.

Updated
May 20, 2026 at 1:37am UTC

A fix is being deployed and will be rolled out in the next few hours.

Updated
May 20, 2026 at 12:40am UTC

We are working to restore our service. We are in direct contact with our providers support team. Right now there is no fixed ETA.

Created
May 20, 2026 at 12:21am UTC

Investigating message

We’re investigating an issue with our API that is impacting some users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly. Currently logging in or signing up is blocked. Already logged in users can reach https://secure.tegasfx.com unaffected